Перейти к содержимому


Правила форума

Внимание!!! Если не можете скачать, пожалуйста ознакомьтесь с условиями получения доступа с файлам форума. Правила форума


Ожидается ли обновление движка ShopCms?

ShopCms

Сообщений в теме: 11

#1 Mamur

    Новичок

  • Пользователи
  • Pip
  • 7 сообщений
Репутация: -3
Начинающий

Отправлено 09 февраля 2015 - 15:41

Ожидается ли обновление движка ShopCms?
Круто было бы если выпустили новую обновленную CMS ку с всеми существующими модулями. ъ
Я бы купил!

#2 badisoft

    Продвинутый пользователь

  • Assistent vsupport.club
  • PipPipPip
  • 5 075 сообщений
Репутация: 786
Мастер

Отправлено 09 февраля 2015 - 19:04

Просмотр сообщенияMamur сказал:

Круто было бы если выпустили новую обновленную CMS ку с всеми существующими модулями.
Нифига не круто. Круто - это если бы со всеми существующими и еще даже не написанными модулями.
http://cpu.badisoft.ru (тестовый сайт), http://badisoft.ru (модули)

#3 namer

    Продвинутый пользователь

  • Download User
  • PipPipPip
  • 45 сообщений
Репутация: 16
Начинающий
  • ГородКрасноярск

Отправлено 11 апреля 2015 - 18:44

ShopCMS в текущей редакции умер.
Однако, ожидается последнее обновление, которое будет направлено на обеспечение совместимости с PHP
5.3 и выше.
В перспективе появление новой платформы, которая возьмет от старого продукта только бренд.
Однако, каталог товаров можно будет перенести и обновление будет
бесплатным.

Спрошу здесь старожил форума - почему мне не доступна загрузка файлов из раздела Download User при репутации 6, когда в правилах сказано

Цитата

Условия перехода в группу Download user
(чтобы получить доступ к скачиванию как с форума, так и с Файлового архива не более 3 файлов в день)

или
1) Заработайте репутацию не мене 2 баллов...

Установка, настройка
доработка функционала
Изображение

#4 badisoft

    Продвинутый пользователь

  • Assistent vsupport.club
  • PipPipPip
  • 5 075 сообщений
Репутация: 786
Мастер

Отправлено 11 апреля 2015 - 23:12

Просмотр сообщенияnamer сказал:

Однако, ожидается последнее обновление, которое будет направлено на обеспечение совместимости с PHP 5.3 и выше.
Буагагага... Совместимость с 5.3 присутствует и так за исключением ерунды. Совместимость с 5.4 обеспечит любой PHP-пионер - добавить кодировку в htmlentity() и заменить используемый для ресайза фоток класс asido на что-нибудь более современное из jquery. Только зачем все это, если любой уважающий себя хостер на выбор предоставляет версию PHP? Как правило, от 5.2 до распоследних.

Все эти мелкие изменения не добавят в ShopCMS ничего нового, без чего не мыслим современный интернет-магазин. В версии 3.1.3 не были исправлены даже ВОПИЮЩИЕ и давно найденные ошибки. Это позволяет думать, что в следующей версии они тоже не будут исправлены, а уж необходимых в современном интернет-магазине модулей не будет и подавно. ЧПУ? sitemap? Выгрузка в Яндекс-Маркет (работающая)? Единая Касса (работающая)? Работа по HTTPS?

Цитата

В перспективе появление новой платформы, которая возьмет от старого продукта только бренд.
Ну, тут не удивил. Оно этими же словами перспективно уже годиков несколько :).
http://cpu.badisoft.ru (тестовый сайт), http://badisoft.ru (модули)

#5 namer

    Продвинутый пользователь

  • Download User
  • PipPipPip
  • 45 сообщений
Репутация: 16
Начинающий
  • ГородКрасноярск

Отправлено 13 апреля 2015 - 10:51

badisoft, а что-нибудь по этому поводу сможете сказать?

Просмотр сообщенияnamer (11 апреля 2015 - 18:44) писал:

почему мне не доступна загрузка файлов из раздела Download User при репутации 6

Установка, настройка
доработка функционала
Изображение

#6 badisoft

    Продвинутый пользователь

  • Assistent vsupport.club
  • PipPipPip
  • 5 075 сообщений
Репутация: 786
Мастер

Отправлено 13 апреля 2015 - 14:45

Просмотр сообщенияnamer сказал:

badisoft, а что-нибудь по этому поводу сможете сказать?
Мог бы - сказал бы :).
Ну откуда же я знаю? Я не админ. Есть админ, логичнее спросить у него.
Личного опыта по переходу границы разрешения даунлоада у меня нет, я за какие-то полезности почти сразу был переведен админом в VIP-группу. За какие - уже не помню.
http://cpu.badisoft.ru (тестовый сайт), http://badisoft.ru (модули)

#7 winni-pyx

    Пользователь

  • Download User
  • PipPip
  • 27 сообщений
Репутация: 0
Начинающий

Отправлено 26 мая 2015 - 14:35

....

Сообщение отредактировал winni-pyx: 26 мая 2015 - 14:49


#8 vr-3d

    Продвинутый пользователь

  • Assistent vsupport.club
  • PipPipPip
  • 53 сообщений
Репутация: 0
Начинающий
  • ГородКраснодар

Отправлено 10 июня 2015 - 13:36

Не подскажите есть какой то алгоритм, по смене движка работающего сайта на новый, шаблон fashionsop не работет, и не понимаю как можно просто залить на хост фаилы с заменой, и админ пхп сменить на вип, на новом движке другая же структура расположение фаилов...

#9 badisoft

    Продвинутый пользователь

  • Assistent vsupport.club
  • PipPipPip
  • 5 075 сообщений
Репутация: 786
Мастер

Отправлено 10 июня 2015 - 14:04

Просмотр сообщенияВасcилий сказал:

по смене движка работающего сайта на новый
С какого старого на какой новый?
Хотя какая разница, я ведь все равно других инструкций кроме этой - http://shopcms.ru/manual_update.html - не встречал :).
http://cpu.badisoft.ru (тестовый сайт), http://badisoft.ru (модули)

#10 Sten

    Пользователь

  • Assistent vsupport.club
  • PipPip
  • 16 сообщений
Репутация: 0
Начинающий

Отправлено 29 июня 2015 - 14:59

Просмотр сообщенияbadisoft (11 апреля 2015 - 23:12) писал:

Буагагага... Совместимость с 5.3 присутствует и так за исключением ерунды. Совместимость с 5.4 обеспечит любой PHP-пионер - добавить кодировку в htmlentity() и заменить используемый для ресайза фоток класс asido на что-нибудь более современное из jquery...

Здравствуйте!
Если не сложно, объясните как подружить shopcms с php 5.3 и с 5.4, какие файлы следует править.
Как я понял, там еще отсутствует поддержка Zend Optimizer.
Порыскав в сети наткнулся на такую инструкцию : http://rx-support.ne...hp52_php53.html . Применимо ли это к нашему движку?
Дело в том что timeweb прекратил поддержку php 5.2 с 15-го июня и все мои сайты на этом движке упали. Речь о лицензионной обычной (не vip) версии движка.

Буду благодарен за помощь

#11 eugene_wb

    Продвинутый пользователь

  • Модераторы
  • 827 сообщений
Репутация: 166
Мастер

Отправлено 29 июня 2015 - 15:32

Перейти на vip, поддержка 5.3 идет по умолчанию
Изображение Изображение Изображение

#12 badisoft

    Продвинутый пользователь

  • Assistent vsupport.club
  • PipPipPip
  • 5 075 сообщений
Репутация: 786
Мастер

Отправлено 29 июня 2015 - 15:46

Цитата

какие файлы следует править.
Никакие. Надо заменить (купить? найти в интернете и скачать?) admin.php и index.php на незакодированные от VIP-версии. В остальном ShopCMS 3.*.* (если речь о нем) нормально работает под PHP 5.3. Вот под 5.4 работать уже не будет.
http://cpu.badisoft.ru (тестовый сайт), http://badisoft.ru (модули)