Перейти к содержимому


Правила форума

Внимание!!! Если не можете скачать, пожалуйста ознакомьтесь с условиями получения доступа с файлам форума. Правила форума


XML Sitemap ShopCMS


Сообщений в теме: 129

#81 plumbum

    Новичок

  • Пользователи
  • Pip
  • 1 сообщений
Репутация: 0
Начинающий
  • ГородМосква

Отправлено 04 июня 2012 - 15:34

Такая же история, дамал все получилось, а sitemap.xml не вижу! Пожалуйста, выручайте.

#82 micehide

    Продвинутый пользователь

  • Assistent vsupport.club
  • PipPipPip
  • 359 сообщений
Репутация: 124
Мастер

Отправлено 10 июня 2012 - 10:43

Уважаемые, ALEXANDERS, tevong и plumbum! Модуль абсолютно рабочий, у всех получалось установить его с первого раза, все ошибки в коде и инструкции были устранены силами пользователей нашего форума еще на начальных этапах обсуждения. Поэтому: пробуйте откатиться на изначальные файлы до установки модуля и установите его заново по инструкции. Используйте этот архив (дополненный и исправленный): Глобальное дополнение XML Sitemap

#83 R.Sergey

    Администратор

  • Администраторы
  • 2 786 сообщений
Репутация: 330
Мастер

Отправлено 10 июня 2012 - 11:19

Все дело в том что они берут модули не с нашего форума. А с сайта одного урода, который натырил их и выложил (зарабатывает на обменниках). Вот только большая часть из всего что он выложил недоделанное и не работает. Вот оттуда и проблемы все.

#84 Papikov

    Продвинутый пользователь

  • Assistent vsupport.club
  • PipPipPip
  • 246 сообщений
Репутация: 66
Продвинутый
  • ГородРостов на Дону

Отправлено 02 июля 2012 - 07:38

Доброго времени суток!

Народ, возникла такая трабла. После установки ЧПУ сайтмап перестал нормально генерировать ссылки на статьи. В хттаццес, правила для статей прописаны выше правил чпу, как и положено. В результате получается вот такая трабла www.сайт.ru/page_ulun.html, хотя статья лежит www.сайт.ru/stati/ulun.html

#85 pavelbred

    Продвинутый пользователь

  • Assistent vsupport.club
  • PipPipPip
  • 194 сообщений
Репутация: 4
Начинающий

Отправлено 03 июля 2012 - 14:03

А что дают настройки приоритета от 0.5-1? По умолчанию стоит 0.5. Как правильно следует выставить?

#86 micehide

    Продвинутый пользователь

  • Assistent vsupport.club
  • PipPipPip
  • 359 сообщений
Репутация: 124
Мастер

Отправлено 06 июля 2012 - 13:56

Просмотр сообщенияpavelbred (03 июля 2012 - 14:03) писал:

А что дают настройки приоритета от 0.5-1? По умолчанию стоит 0.5. Как правильно следует выставить?

Читаем первоисточник: http://www.sitemaps.org/protocol.html

Просмотр сообщенияPapikov (02 июля 2012 - 07:38) писал:

Доброго времени суток!

Народ, возникла такая трабла. После установки ЧПУ сайтмап перестал нормально генерировать ссылки на статьи. В хттаццес, правила для статей прописаны выше правил чпу, как и положено. В результате получается вот такая трабла www.сайт.ru/page_ulun.html, хотя статья лежит www.сайт.ru/stati/ulun.html

Если проблема только в файле siemap.xml, а в ЧПУ статей все впорядке, то посмотри в файле /core/includes/admin/sub/modules_xml_sitemap.php строку, относящуюся к генерации карты статей, потому как сама генерация происходит именно там и .htacess тут совершенно не при чем.

#87 ALEXANDERS

    Пользователь

  • Download User
  • PipPip
  • 28 сообщений
Репутация: 0
Начинающий

Отправлено 12 июля 2012 - 08:50

У меня пропадает сгенерированый файл после сохранения в общих настройках. Если в общие настройки зайти и нажать сохранить, то по нужному адресу - 404 страница не найдена. Так и должно быть?

#88 Papikov

    Продвинутый пользователь

  • Assistent vsupport.club
  • PipPipPip
  • 246 сообщений
Репутация: 66
Продвинутый
  • ГородРостов на Дону

Отправлено 12 июля 2012 - 10:23

Цитата

Если проблема только в файле siemap.xml, а в ЧПУ статей все впорядке, то посмотри в файле /core/includes/admin/sub/modules_xml_sitemap.php строку, относящуюся к генерации карты статей, потому как сама генерация происходит именно там и .htacess тут совершенно не при чем.

Так до установки ЧПУ все работало, и статьи генерировались нормально.

#89 FineD

    Пользователь

  • Пользователи
  • PipPip
  • 19 сообщений
Репутация: 0
Начинающий

Отправлено 05 октября 2012 - 20:01

сделал все по инструкции,видел в начале темы тоже с этим стыкались, при переходе на сайт мап пишет:
Not Found

The requested URL /xml_sitemap.php was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


#90 sergio3004

    Пользователь

  • Assistent vsupport.club
  • PipPip
  • 29 сообщений
Репутация: 65
Продвинутый
  • ГородМосква

Отправлено 13 октября 2012 - 01:47

Просмотр сообщенияALEXANDERS (12 июля 2012 - 08:50) писал:

У меня пропадает сгенерированый файл после сохранения в общих настройках. Если в общие настройки зайти и нажать сохранить, то по нужному адресу - 404 страница не найдена. Так и должно быть?
Сам файл генерируется в папку cache, если стоит галочка на принудительную очиску кеша в общих настройках, то файл удалится вместе с кешем, снимайте галочку и сново генерите sitemap.xml.
Я зделал иначе, перезалил сгенерированный файл sitemap.xml в корень сайта, переписал пути xml_sitemap.php.
Минус этого, то что при добавлении товара на сайт надо в ручную заменять файл на новый.

#91 wwwsasa2

    Продвинутый пользователь

  • Download User
  • PipPipPip
  • 53 сообщений
Репутация: -1
Начинающий
  • ГородКиев

Отправлено 15 октября 2012 - 21:57

Подскажите плиз все сделал файл генерируется куда нужно но не открывается что делать? Даже на ФТП посмотреть можно открывать зараза не хочет.

#92 NEViL

    Продвинутый пользователь

  • Download User
  • PipPipPip
  • 42 сообщений
Репутация: 4
Начинающий

Отправлено 15 ноября 2012 - 17:53

Подскажите, как сделать что бы галочки "что генерировать" стояли по умолчанию. И значение приоритета тоже. Например не 0,1 везде, а где-то 0,1 где-то 0,5 ???

#93 micehide

    Продвинутый пользователь

  • Assistent vsupport.club
  • PipPipPip
  • 359 сообщений
Репутация: 124
Мастер

Отправлено 15 ноября 2012 - 23:52

Просмотр сообщенияNEViL (15 ноября 2012 - 17:53) писал:

Подскажите, как сделать что бы галочки "что генерировать" стояли по умолчанию. И значение приоритета тоже. Например не 0,1 везде, а где-то 0,1 где-то 0,5 ???
Очевидно, открыть файл /core/tpl/admin/xml_sitemap.tpl.html и поковырять HTML-код расставив нужные галки и параметры по умолчанию...

#94 NEViL

    Продвинутый пользователь

  • Download User
  • PipPipPip
  • 42 сообщений
Репутация: 4
Начинающий

Отправлено 16 ноября 2012 - 08:28

Галки по умолчанию выставил в /core/tpl/admin/xml_sitemap.tpl.html
в 4-х строках
<input type="checkbox" id="includeCatalog" name="includeCatalog" value="1"  />

добавил параметр checked вышло в итоге так

<input type="checkbox" id="includeCatalog" name="includeCatalog" value="1" checked />

А вот со значениями приоритета не особо получается.

#95 micehide

    Продвинутый пользователь

  • Assistent vsupport.club
  • PipPipPip
  • 359 сообщений
Репутация: 124
Мастер

Отправлено 19 ноября 2012 - 05:06

Просмотр сообщенияNEViL (16 ноября 2012 - 08:28) писал:

А вот со значениями приоритета не особо получается.
А что там должно получаться? Если вы по инструкции устанавливали мое глобальное дополнение, то там автоматически запоминаются последние настройки приоритета и в следующий раз проставляются из базы.

#96 neowolf

    Новичок

  • Download User
  • Pip
  • 4 сообщений
Репутация: 0
Начинающий

Отправлено 19 ноября 2012 - 07:47

Просмотр сообщенияSalp (15 февраля 2012 - 14:27) писал:

Да, на счет новостей. У меня ссылка на новости стандартная: http://мой_сайт/news.html, а скрипт генерирует http://мой_сайт/FU_NEWS_ROOT.html

У меня такая же проблема.
Кусок кода из файла sitemap:
<!--  News  -->
<url>
<loc>http://www.site.ru/FU_NEWS_ROOT.html</loc>
<changefreq>daily</changefreq>
<priority>0.5</priority>
</url>
<url>
<loc>http://www.site.ru/show_news_3.html</loc>
<lastmod>2012-01-18</lastmod>
<changefreq>monthly</changefreq>
<priority>0.5</priority>
</url>

Первая ссылка я так понял на страницу новостей ведет, вот она как то криво отображается, а уже на сами новости ссылки верные.
Я так понял надо править файл modules_xml_sitemap.php

// News
		  if(isset($_POST['includeNews']) && !$modxError) {
   $news_root = FU_NEWS_ROOT ? FU_NEWS_ROOT : "news";
   fwrite($handle, "  <!-- News -->\n   <url>\n	  <loc>http://" . CONF_SHOP_URL . "/" . $news_root . ".html</loc>\n	  <changefreq>$tags_news</changefreq>\n	  <priority>" . $_POST['tagsNews'] . "</priority>\n   </url>\n");
		    $fieldsList = function_exists('fu_make_url_news') && MODX_FRIENDLY_URLS_COMPATIBILITY ? 'NID, uri' : 'NID';
		    $sql = "SELECT $fieldsList, add_date
				    FROM " . NEWS_TABLE;
		    $result = db_query($sql);

Подскажите пожалуйста, что поменять?

#97 micehide

    Продвинутый пользователь

  • Assistent vsupport.club
  • PipPipPip
  • 359 сообщений
Репутация: 124
Мастер

Отправлено 20 ноября 2012 - 00:11

Цитата

Да, на счет новостей. У меня ссылка на новости стандартная: http://мой_сайт/news.html, а скрипт генерирует http://мой_сайт/FU_NEWS_ROOT.html

Salp и neowolf, установлен ли у вас модуль ЧПУ? Если да, то посмотрите в файле url_rewriter.php в корне сайта - на самом верху строчка есть:

define('FU_NEWS_ROOT', 'news');

- такая ли она? и есть ли вообще?

В противном случае просто задайте переменной $news_root в modules_xml_sitemap.php ссылку, которая должна указывать на корневой раздел новостей типа:

$news_root = 'news';


#98 neowolf

    Новичок

  • Download User
  • Pip
  • 4 сообщений
Репутация: 0
Начинающий

Отправлено 20 ноября 2012 - 05:30

Просмотр сообщенияmicehide (20 ноября 2012 - 00:11) писал:


В противном случае просто задайте переменной $news_root в modules_xml_sitemap.php ссылку, которая должна указывать на корневой раздел новостей типа:

$news_root = 'news';

Модуль ЧПУ не установлен.
Правка сработала, спасибо.

#99 wwwsasa2

    Продвинутый пользователь

  • Download User
  • PipPipPip
  • 53 сообщений
Репутация: -1
Начинающий
  • ГородКиев

Отправлено 27 ноября 2012 - 13:06

Проблема была решена. Оказалось что в настройках сайта моего Хостинга нужно было поставить возможность чтения формата XML. Внимание колегу кто пользуется услугами хостинг украина у Вас может возникнуть такаяже проблема. Нужно в панеле управления зайти в настройки сайта, и в чтении статических файлов добавить возможность чтения формата XML. Только и делов, а мучался 3 дня. :D

#100 Lonely_Virus

    Новичок

  • Пользователи
  • Pip
  • 2 сообщений
Репутация: 0
Начинающий

Отправлено 06 декабря 2012 - 01:49

Кто поможет поставить?